Back to overview
Resolved

isotope blew up

May 19, 2026 at 7:30pm UTC
Affected services
isotope.sites.tjhsst.edu

Resolved
Jun 7, 2026 at 6:34pm UTC

fixed

Updated
May 29, 2026 at 12:13am UTC

waiting for my director site to be fixed :(

Created
May 19, 2026 at 7:30pm UTC

because tj servers blew up!